Deleting a segment fails in NSX-T with stuck in "In Progress" error_code=600
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Deleting a segment fails in NSX-T with stuck in "In Progress" error_code=600

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Article ID: 404168

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Updated On:

Products

VMware NSX

Issue/Introduction

  • You are unable to delete a segment. It is stuck in an "In Progress" state.
  • You may see this error in the UI due to a logical port that is still associated with the segment, preventing its deletion.

Unable to delete logical port with attachments of LogicalPort InternalLogicalPort/########-####-####-######## in the UI.

  • You may see the following log message in the NSX Manager file /var/log/syslog.log 

2025-06-30T19:21:02.927Z <NSX-Manager> NSX 77722 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM0" level="ERROR" subcomp="manager"] Created alarm Alarm [policyPath=/infra/realized-state/enforcement-points/default/logical-switches/<Segment-name>/alarms/########-####-####-########, message=The requested object : LogicalPort/########-####-####-######## could not be found. Object identifiers are case sensitive.,errorId=PROVIDER_INVOCATION_FAILURE, path=null, apiError=error_code=600, module_name=common-services, error_message='The requested object : LogicalPort/########-####-####-######## could not be found. Object identifiers are case sensitive.', sourceSiteId=null].

Environment

VMware NSX

Cause

NSX is unable to delete the segment as it has a stale logical port attached. This is a known issue in older releases.

Resolution

This issue is resolved in VMware NSX 4.2, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

 

Workaround:

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

Additional Information