ESXi host prepared for NSX does not connect with vcenter after upgrade from ESXi 7.0 to 8.0, host UI page returns "no healthy upstream" and hostd process is stopped
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ESXi host prepared for NSX does not connect with vcenter after upgrade from ESXi 7.0 to 8.0, host UI page returns "no healthy upstream" and hostd process is stopped

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Article ID: 403623

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Updated On:

Products

VMware NSX VMware vSphere ESXi 8.0

Issue/Introduction

  • After ESXi hosts are upgraded from 7.0.3 to 8.0 P05, the hosts were unable to connect with vcenter.  The ESXi hosts were prepared for NSX 4.2.2 and were reachable via SSH.
  • The Host UI page was not loading and the error "no healthy upstream" was reported while accessing vSphere as below
  • When checking the Distributed Virtual Switch (DVS) on the ESXi using the below command  , forwardingMode property is set before vdl2.enabled.   
                    net-dvs -l | grep com.vmware.nsx
                    com.vmware.nsx.vdl2.enabled = true ,    propType = CONFIG
                    com.vmware.nsx.vdr.dvptracking =  ,     propType = CONFIG POLICY
                    com.vmware.nsx.spf.enabled = true ,     propType = CONFIG
                    com.vmware.nsx.kcp.enable = true ,      propType = CONFIG
                    com.vmware.nsxData.traceflow.enabled = true ,   propType = CONFIG
                    com.vmware.nsx.vdsSecurity.enabled = false ,    propType = CONFIG
                    com.vmware.nsx.vdl2.tepIPv6AssignType =  ,      propType = CONFIG
                    com.vmware.nsxData.vdl2.forwardingMode = 0x 0. 0. 0. 1
                    com.vmware.nsx.vxlan.vmknic = 0x 0. 1.2c. 1
                    


Environment

ESXi 8.0 P05

NSX 4.2.2.0 

Cause

During ESXi upgrade, the order of setting parameters "com.vmware.nsxData.vdl2.forwardingMode", "com.vmware.nsx.vdl2.enabled" on DVS got disorganized.

Here "com.vmware.nsxData.vdl2.forwardingMode" got set before "com.vmware.nsx.vdl2.enabled" and therefore causing the failure.

 

Resolution

This issue is resolved in VMware NSX  4.2.3 , available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.