vCenter Server Managed Object Browser (MOB) reports a 503 Service Unavailable error
search cancel

vCenter Server Managed Object Browser (MOB) reports a 503 Service Unavailable error

book

Article ID: 403417

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Cannot access vCenter server Managed Object Browser(MOB) at https://<VC-FQDN> or <VC-IP>/mob/
  • Browser reports error as "503 Service Unavailable" or "no healthy upstream" Note: All vCenter services are up and running.

Environment

VMware vCenter Server 7.0.x

VMware vCenter Server 8.0.x

Cause

The issue occurs if the <enableDebugBrowse> parameter in the vpxd.cfg config file is set to false.

<vpxd>

...

...

  <enableDebugBrowse>false</enableDebugBrowse>

...

...

</vpxd>

Resolution

Note: Ensure there is a valid backup/offline snapshot of the VCSA prior to implementing the workaround. Refer to VMware vCenter in Enhanced Linked Mode pre-changes snapshot (online or offline) best practice.

1.Take a snapshot of the vCenter Server.

2. Login to vCenter via SSH and type shell to enter the Bash shell.

3.Backup the vpxd.cfg file.

  • cp /etc/vmware-vpx/vpxd.cfg  /storage/core/vpxd.cfg 

4.Navigate to the config directory and edit the vpxd.cfg file using the vi editor.

  • cd /etc/vmware-vpx
  • vi vpxd.cfg 

5. Locate the <enableDebugBrowse> entry within vpxd.cfg, and either remove the entry or change its value to true.

<vpxd>

...

...

<enableDebugBrowse>true</enableDebugBrowse>

...

...

</vpxd>

6.Restart the vCenter services for the changes to take effect. For details, please refer to Stopping, Starting or Restarting VMware vCenter Server Appliance services .

  • service-control --stop --all && service-control --start --all