ESXi PSOD with "Panic Message: @BlueScreen: VERIFY bora/vmkernel/sched/cpusched.c:11252"
search cancel

ESXi PSOD with "Panic Message: @BlueScreen: VERIFY bora/vmkernel/sched/cpusched.c:11252"

book

Article ID: 401190

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • ESXi 8.x hosts experience a Purple Screen of Death (PSOD) with the below backtrace:

Panic Details: Crash at 20XX-XX-XXTXX:XX:XX.XXXZ on CPU 62 running world 20xxxxx. VMK Uptime:XXX:XX:XX:XX.XXX
Panic Message: @BlueScreen: VERIFY bora/vmkernel/sched/cpusched.c:11252
Backtrace (top 8 lines):
  XxXXXaXXXXbbXX:[XxXXXXXXXXbbcX]PanicvPanicInt@vmkernel#nover+XxXXc stack: XxXXXaXXXXfXXX, XxXXXXXXXXbbcX, XxX, XxXXXXXXXXXXX1, XxXXXXXXXXbbcX
  XxXXXaXXXXbcXX:[XxXXXXXXXXcXXc]Panic_NoSave@vmkernel#nover+XxXd stack: XxXXXaXXXXbcXX, XxXXXaXXXXbcXX, XxX, XxXXXXXXXXXeaX, XxXbfX
  XxXXXaXXXXbcXX:[XxXXXXXXXXcXXX]Panic_OnAssertAt@vmkernel#nover+0xba stack: XxXbfX00000000, XxXXXXXXXXXeaX, XxXXXXXXXXXdXX, XxXXXXXXXXXfXX, XxXXXXXXXXXXXX
  XxXXXaXXXXbdXX:[XxXXXXXXXaXXeX]Int6_UD2Assert@vmkernel#nover+0xXX0 stack: 0x0, 0x0, 0x0, 0xXXXXXXXXbXcX, 0x0
  XxXXXaXXXXbdXX:[XxXXXXXXXXbXcX]gate_entry@vmkernel#nover+XxaX stack: 0x0, Xxbfffffff, 0x0, XxXXXffeebXcXXXX, 0x0
  XxXXXaXXXXbdfX:[XxXXXXXXXdXXXf]CpuSchedWait@vmkernel#nover+XxXXb stack: XxXXXXXXXXXXXXXXXX, 0x0, 0x0, XxXXeXXcXXXXXX, XxXXXaXXXXbfXX
  XxXXXaXXXXbfXX:[XxXXXXXXXeXXXa]TcpipDispatchWorld@(tcpip4)#<None>+XxXXX stack: 0x0, 0x0, 0x0, 0x0, 0x0
  XxXXXaXXXXbfeX:[XxXXXXXXXdXXbX]CpuSched_StartWorld@vmkernel#nover+Xxbf stack: 0x0, XxXXXXXXXXXcfX, 0x0, 0x0, 0x0

Environment

VMware vSphere ESXi 8.x

Cause

The crash is caused by an incorrect CPU preemption state. This is a per-CPU state monitored by the VMkernel scheduler; when an unexpected state is detected, the kernel triggers an assertion failure.

 

Resolution

There is currently no resolution. Broadcom is working on code changes which will be included in a further release.

Engage the hardware vendor to perform exhaustive diagnostics on CPU and memory to rule out underlying physical defects.

If the issue is reproducible, engage Broadcom Support.