ESXi transport node preparation in a vLCM enabled vSphere cluster fails
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ESXi transport node preparation in a vLCM enabled vSphere cluster fails

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Article ID: 400800

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Preparation of ESXi transport node has failed in NSX
  • The issue occurs in a vLCM-enabled vSphere cluster
  • You recently reinstalled the ESXi host
  • The image used for the ESXi host is different from the one used for the rest of the hosts in the cluster
  • ESXi transport node preparation in NSX fails with the error shown in the screenshot below




    Failed to install software on host. Solution apply failed because the vSphere Lifecycle image contains either a new ESXi version or a new addons version or new components. Please proceed to the vSphere Client Lifecycle Manager to update ESXi or addons or components along with the solution 'com.vmware.nsxt' Solution apply failed on host: 'esxi-host.domain.com'. The 'vmware-perccli64-esxi8' component version '007.2110.0000.0000-02' was deleted from vSphere Lifecycle image. Please proceed to the vSphere Client Lifecycle Manager to delete the component and update the solution 'com.vmware.nsxt'Solution apply failed on host: 'esxi-host.domain.com'




Environment

VMware NSX 
VMware vSphere 

Cause

The issue occurs because the desired state in vLCM is not the same as the ESXi Host. 

Resolution

To resolve the issue, make sure to use the same image for all the ESXi hosts in the vSphere vLCM cluster and remediate the cluster successfully. 

Once done, the host preparation can be initiated from the NSX and LCM will initiate the Apply NSX Solution task to install the NSX vibs on the host. 


Note: The solution-apply operation only adds the solution vibs but does not update base ESX. If base ESX is getting updated, the solution-apply operation will be rejected/failed. 

Additional Information

Before applying TNP on the cluster, host should be already compliant (ESX OS, other components, ovf tools etc.)

Prepare an NSX Cluster with vSphere Lifecycle Manager

If the issue persists even after fixing the image, please open a support ticket with Broadcom Support and select NSX as the product.

Handling Log Bundles for offline review with Broadcom support