"Failed to install software on host" when configuring NSX-T on an ESXi host
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"Failed to install software on host" when configuring NSX-T on an ESXi host

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Article ID: 399712

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Updated On:

Products

VMware NSX

Issue/Introduction

  • When configuring an ESXi host as an NSX transport node from the NSX UI , the deployment fails with the following error:
      Failed to install software on host. Unable to connect the host https://x.x.x.x/sdk

  • On the ESXi host, navigate to Configure → Networking → VMkernel adapters , a VMkernel adapter with the reported IP address (the one referenced in the error) is present and is configured to use the default TCP/IP stack.

Environment

VMware NSX

Cause

  • The NSX Inventory service detected a VMkernel interface on the host that uses the default TCP/IP stack and has the IP address x.x.x.x.
  • NSX is unable to connect to this IP address either due to routing issues or port 1234/1235 connectivity problem.
  • This issue can also occur if multiple VMkernel adapters are tagged as Management, and NSX attempts to connect to one of them that is unreachable.

Resolution

  • On the affected ESXi host, ensure that VMK0 has a valid and routable IP address that can reach the NSX Manager.
  • It is recommended to use only one VMkernel adapter with the Management tag.

You can use netcat (nc) to confirm connectivity to the TCP ports (443,80 and 902) from the NSX Manager(s) to the Host Transport node: 

  1. Open SSH to NSX Manager and log in using root account
  2. run the following command to check the connectivity on TCP port 443:
    #nc -zv <host-ip> 443
  3. Example response when connection succeeded:
    Connection to <host_ip> 443 port [tcp/*] succeeded!
  4. Repeat the same steps for ports 80 and 902
  5. If the connection is not successful, then investigate with your firewall team where the port may be blocked.
  6. Check the connection from all three NSX Managers.

You can use netcat (nc) to confirm connectivity to the TCP ports (443, 1234 and 1235) from the Host Transport node(s) to the NSX Manager(s)

  1. Open SSH to Host Transport node and log in using root account
  2. run the following command to check the connectivity on TCP port 443:
    #nc -zv <NSX_Manager_IP> 443
  3. Example response when connection succeeded:
    Connection to <NSX_Manager_IP> 443 port [tcp/*] succeeded!
  4. Repeat the same steps for ports 1234 and 1235
  5. If the connection is not successful, then investigate with your firewall team where the port may be blocked.
  6. Check the connection from the Host Transport node to all 3 NSX Managers.

Additional Information

 

  1. NSX Manager support bundles.
  2. ESXi host support bundles for hosts that are failing to configure as transport nodes.
  3. Text of any error messages seen in NSX GUI or command lines pertinent to the investigation.

 

  • Handling Log Bundles for offline review with Broadcom support:
  1. Collect Support Bundles for Troubleshooting VMware NSX
  2. Uploading files to cases on the Broadcom Support Portal
  3. Creating and managing Broadcom support cases