Switchover Triggers Immediately after Editing Scheduled Time in Mobility Migration Group
search cancel

Switchover Triggers Immediately after Editing Scheduled Time in Mobility Migration Group

book

Article ID: 399418

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • Changing the switchover schedule date for mobility groups via the new Migration Dashboard triggers an immediate switchover.
  • This issue is only noticed in HCX 4.11.0 versions.
  • The issue is not encountered if we use Legacy Display on the Migration Page.
  • In common/logs/admin/web.log, we see lines like:
    2025-09-01 09:06:34.958 UTC [https-jsse-nio-###.#.#.#-####-exec-10, Ent: HybridityAdmin, , TxId: TxId: ######-####-####-####-#############] INFO  c.v.v.h.a.m.MobilityGroupRestController- Schedule request {"mobilityGroupDefaults":{"switchover":{}}} accepted  for mobility group id : ########-####-####-####-############## 

Environment

VMware HCX 4.11.0

Cause

This occurs because HCX Manager is unable to resolve the time zone using the built-in time-zone list during migration window configuration.
As a result, HCX creates a malformed data object with an invalid schedule, resulting in an immediate switchover.

Resolution

This issue is resolved in VMware HCX 4.11.1 or later versions, available at Broadcom downloads.
If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

WORKAROUND:

  • Ensure that UTC is selected in the timezone dropdown if no timezone is already selected, and then set the desired UTC time.

    OR

  • Use the legacy migration page [Switch to Legacy Display] to update or modify the scheduled switchover date.

Additional Information

HCX 4.11.1 Release Notes
Fixed Issue 3527088: In version 4.11.0, changing the schedule date for mobility groups via the new Migration Dashboard might trigger an immediate switchover if a timezone is not explicitly selected.