Error while creating a new computer in GSS Console
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Error while creating a new computer in GSS Console

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Article ID: 398459

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

When creating a new computer in the Ghost Solution Suite console, a 'Symantec Ghost Solution Suite' error dialog box appears with: Error updating computer record for line 0

Environment

GSS 3.x

Cause

In at least one instance of this issue, the error was observed after the following GSS server migration scenario:

A new GSS server was built with SQL Server installed on-box. The eXpress database as well as its MDF and IDF files were copied from an old GSS server installation onto the new server. The service account user was able to open the console but received the error when attempting to create a new computer in the console.

Resolution

When coping the MDF and IDX files, the user and permissions are not copied or exported to the new server

After installing the new GSS 3.3 RU12 server, the service or user account did not have permission to update the eXpress database tables.

The process to edit user permissions for the eXpress database used with Ghost Solution Suite are as follows:

NOTE: Screenshots represented in this tutorial may or may not reflect actual windows seen during your individual setup process. Database location and user accounts may be different!

1. Download and Install the latest version of SQL Server Management Studio if not already installed.

  

2. Open SQL Management Studio and enter the GSS server connection information. 

3. Expand the tabs in the left hand pane to Security->Logins. Right click on a user and select Properties

 

4. Select General on the left and verify the user is in the Login name: text box.

Make sure the default database is the GSS database name.

 

5.  Then navigate to the Server Roles tab on the left hand pane and make sure public and sysadmin options are checked for server roles.

 

6. Navigate to the User Mapping tab and select the GSS database. Also make sure db_owner and public check-boxes are selected in the below role membership field.

7. Select "OK" at the bottom of the Login Properties

Additional Information

If you need to add a user please follow this document: Steps to add a user to the Ghost Solution Suite database