Exporting SRM configuration data got Error: "Unable to generate file. moRef".
search cancel

Exporting SRM configuration data got Error: "Unable to generate file. moRef".

book

Article ID: 397138

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Try to export the SRM configuration but failed , got the Error: "Unable to generate file. moRef"

Try to export the SRM configuration by /opt/vmware/impex/bin/export.sh without errors, but got null file

Checked impex.log seen some wrong with the array manager issued the export failed .

YYYY-MM-DD 11:16:06,323 [srm-reactive-thread-6] ERROR com.vmware.srm.client.impex.Main - Export SRM configuration ended.
java.lang.IllegalArgumentException: moRef
        at org.apache.commons.lang.Validate.notNull(Validate.java:192)

..............

com.vmware.srm.client.impex.configurables.arrayManagers.ArrayManagerConverter.fromVmodl(ArrayManagerConverter.java:85)
        at com.vmware.srm.client.impex.exporters.arrayManagers.ArrayManagersExporter.lambda$getSingleSiteConfigurables$0(ArrayManagersExporter.java:25)

Environment

VMware Live Site Recovery 

VMware Site Recovery Manager

Cause

There are stale array manager in SRM database  . 

Resolution

Contact the Broadcom support through https://knowledge.broadcom.com/external/article/206567/contact-broadcom-support.html to log a case to fix it .

Before log the case , please collect the VMware Live Site Recovery / VMware Site Recovery Manager log bundle , and dump the SRM database  .