Management Center GUI displays a 404 error. Disk usage shows Error: psql: error: could not connect to server: FATAL: database "bccm" does not exist
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Management Center GUI displays a 404 error. Disk usage shows Error: psql: error: could not connect to server: FATAL: database "bccm" does not exist

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Article ID: 397050

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Updated On:

Products

Management Center - VA Management Center

Issue/Introduction

When trying to use the Management Center (MC) GUI you receive a 404 error. However, you can still use ssh (or serial console).

When checking the disk usage, you will see the normal disk usage but at the end of the output you will see the error message:

psql: error: could not connect to server: FATAL:  database "bccm" does not exist

The display will look like this:

# show disk-usage
Directory usage:
  23M       /boot
  15M       /etc
  253M      /var
  149M      /var/log
  1.6M      /var/log/clp
  20K       /cache-data
  0         /config
  70M       /config/pgsql12-data
  8.0K      /config/pgsql12-data/log
  105M      /config/var
  79M       /core
  65M       /core/userspace
  13G       /data
  13G       /data/bluecoat
  8.8M      /data/bluecoat/appstats
  1010M     /data/bluecoat/backups
  6.8G      /data/bluecoat/bccm
  11M       /data/bluecoat/bccm/art
  2.4G      /data/bluecoat/bccm/fs
  4.3G      /data/bluecoat/bccm/rt
  162M      /data/bluecoat/bccm/rt/cache
  4.0G      /data/bluecoat/bccm/rt/jcr
  102M      /data/bluecoat/bccm/rt/serviceability
  1.6M      /data/bluecoat/bccm/rt/serviceability/eventlogs
  100M      /data/bluecoat/bccm/rt/serviceability/logs
  9.8M      /data/bluecoat/bccm/rt/serviceability/logs/access
  4.3M      /data/bluecoat/bccm/rt/serviceability/logs/debug
  20M       /data/bluecoat/bccm/rt/serviceability/logs/diagnostics
  4.0K      /data/bluecoat/bccm/rt/serviceability/logs/performance
  4.0K      /data/bluecoat/bccm/rt/serviceability.bak
  4.7G      /data/bluecoat/clp
  16K       /data/bluecoat/clp/etc
  4.0K      /data/bluecoat/clp/syscfg
  8.0K      /data/bluecoat/clp/syscfg_v2
  4.5G      /data/bluecoat/clp/syscfg_v4
  4.0K      /data/bluecoat/clp/sysinfo
  149M      /data/bluecoat/clp/syslog
  4.3M      /data/bluecoat/clp_services
  4.0K      /data/bluecoat/clp_services/images
  4.3M      /data/bluecoat/clp_services/subscription
  15M       /etc
  8.5M      /encrypted-data
  359M      /opt
  756K      /tmp
  4.0K      /tmp/offline-report-files
  253M      /var
Database usage:
  bccm
  bccm_appstat
Filesystem                          Size  Used Avail Use% Mounted on
/dev/mapper/vg_persist-core         9.8G  102M  9.2G   2% /core
/dev/mapper/encrypted-data          9.2G   30M  8.7G   1% /encrypted-data
/dev/mapper/vg_persist-cache--data  4.6G  9.5M  4.3G   1% /cache-data
/dev/mapper/vg_persist-data         336G   13G  307G   4% /data
none                                7.8G  996K  7.8G   1% /tmp
psql: error: could not connect to server: FATAL:  database "bccm" does not exist
psql: error: could not connect to server: FATAL:  database "bccm" does not exist

Environment

You have upgraded from an older version at least two minor revisions some time in the past. For example, you may have upgraded from MC 3.1.4.1 to MC 3.3.3.1 on the MC at some point.

Cause

The MC database version changed.

If the version displayed is older than the most recent version that you upgraded the MC to, then this is the root cause of the issue.

The MC database version changes with upgrades and may become unreadable after two minor release upgrades.

The error message: "psql: error: could not connect to server: FATAL:  database "bccm" does not exist" is saying MC cannot read the format of the database since it has changed.

Resolution

Check the version of MC from the CLI using the command:

# show version

and verify that you are running the most recent version on your MC.

You can use the: "installed-systems" command to verify the version the system default and make any changes necessary.

See CLI guide - installed-systems

Alternatively, you may have to restart the MC and interrupt the boot sequence of the MC and choose the latest version in the boot menu.

With the serial console attached, restart the MC.

When the boot menu appears, press the 'space bar' before five seconds elapses. If you do not press the 'space bar' in time, you will need to restart the process.

Select the correct image (the latest updated one) then the MC will boot. The issue should be resolved after the MC completely boots and the GUI should become accessible a few minutes later.

If this procedure does not resolve the issue, the database has become corrupt and you will need to factory default the MC and restore the MC from backup.

 

Additional Information