Disk group unhealthy after adding disk previously used in another vSAN cluster
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Disk group unhealthy after adding disk previously used in another vSAN cluster

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Article ID: 396756

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Updated On:

Products

VMware vSAN 7.x VMware vSAN 8.x

Issue/Introduction

Symptoms: 

  • Disk group shows as unhealthy in Cluster -> Configure Tab -> Disk Management: 

  • Disk appears in a new disk group without having added it, along with an absent cache disk that had not previously existed: 

  • The disk does not appear in the "Ineligible and Unclaimed"  section in Cluster -> Configure Tab -> Disk Management.

Environment

  • VMware vSAN 7.x
  • VMware vSAN 8.x

Cause

  • vSAN will try to automatically mount a vSAN disk that appears to have valid vSAN partition on it, so will not be eligible to be claimed for a new or existing disk group. 

Resolution

Follow these steps to resolve this issue: 

  1. Remove the disk from vSAN disk group.  See KB: How to remove a disk from a vSAN disk group/host
  2. Erase the partitions on the disk. See TechDocs: Erase ESXi Storage Devices
    • CAUTION:  Ensure the data on the disk is not longer needed before erasing the partitions.
  3. Add the disk to new or existing disk groups, as needed.   See TechDocs:  Add Devices to the Disk Group in vSAN Cluster and Create a Disk Group or Storage Pool in vSAN Cluster