Message: "Resynchronization has been suspended for some objects because there is not enough storage space on one or more disk groups. Check cluster health for details" is noticed on the vSAN resyncing objects tab UI after disk group recreation.
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Message: "Resynchronization has been suspended for some objects because there is not enough storage space on one or more disk groups. Check cluster health for details" is noticed on the vSAN resyncing objects tab UI after disk group recreation.

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Article ID: 396487

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • A resync is running, and the user notices the following message on the vSAN resyncing objects tab UI after the disk group is recreated after a failure.

"Resynchronization has been suspended for some objects because there is not enough storage space on one or more disk groups. Check cluster health for details."

Environment

VMware vSAN 7.0.x

VMware vSAN 8.0.x

Cause

  • This is expected behavior when there are multiple disk groups in the ESXi host and the failed disk group is out of the vSAN for a longer time.

  • While the disk group is offline, the data on the failed disk group is already synced to the available disk group, along with new data to maintain object compliance, which made the available disk group consume more space.

  • When the new disk group is created, the vSAN starts a resync for rebalancing the data across the disk group, but since one disk group is heavily used while the other disk group was out of the cluster, the vSAN displays the message while vSAN calculates which objects can be moved to the other available, relatively free disk group.

Resolution

  • This is expected behavior. To maintain compliance, vSAN calculates which data it can move to the other disk group and takes its time to complete the task.

  • The resync may be suspended for some objects while vSAN does the calculation, but eventually the resync will complete and the usage for the disk groups on the ESXi host will be balanced. The user can run the following command on the ESXi CLI to make sure that the resync is progressing and the number of objects, Total bytes to sync and Total GB left section is changing.

esxcli vsan debug resync summary get

  • For any other reason, like the vSAN datastore being full with no disk group failed, the user needs to either free up space or add more storage to let the resync task complete.

  • To free up space on the vSAN datastore, we have the following options: