"Unknown object type" inaccessible vSAN objects
search cancel

"Unknown object type" inaccessible vSAN objects

book

Article ID: 396435

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • vSAN Skyline Health alert "vSAN Object Health" reports inaccessible vSAN objects
  • Viewing the inaccessible objects indicate that it is all of "Unknown object type":

  • No VMs are impacted on this vSAN cluster.

Environment

VMware vSAN 7.x

VMware vSAN 8.x

Cause

vSAN objects become inaccessible when there are not enough Active components. 

  • This can happen if hosts are in vSAN Decom/ESXi maintenance mode

  • Failed disks/disk groups

  • Network partition

  • vSAN cluster shutdown/restart is in an inconsistent state

  • Stale inaccessible objects can also remain if there were any intermittent network or host issues (Example: host crashed and brough online after some time) in the cluster.

Resolution

  • To clear inaccessible VM Swap objects follow the "Purge inaccessible VM Swap Objects" instructions in the Skyline health alarm. The inaccessible VM Swap Objects can be removed without risk. 

  • If inaccessible objects still exist after clicking on "Purge inaccessible VM Swap Objects" please open a case with Broadcom Technical Support to investigate further.