/opt/vmware/support on Site Recovery Manager got filled on running the clean-sras-logs.sh
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/opt/vmware/support on Site Recovery Manager got filled on running the clean-sras-logs.sh

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Article ID: 395256

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • The /opt/vmware/support/logs/srm/SRAs partition on the Site Recovery Manager appliance (SRM) was full, so the clean-sras-logs.sh script was run as per KB - SRM services stop due to unmanaged SRA log files.
  • The script fails to complete with the error:

root@SRM[ /opt/vmware/bin ]# clean-sras-logs.sh error: error writing to /opt/vmware/support/logs/srm/olddir/discoverDevices_YYYY-MM-DD-HH-MM-SS-2023019-3fe2b491-be60-4e0c-bfa7-21bf813e4f1f.log.1: No space left on device

  • Now the /opt/vmware/support partition is also full:

admin@SRM[~]$ df -h
Filesystem                      Size  Used Avail Use% Mounted on
/dev/mapper/support_vg-support  3.9G  3.9G     0 100% /opt/vmware/support
/dev/loop0                      2.3G  2.2G  8.9M 100% /opt/vmware/support/logs/srm/SRAs

Environment

VMware Site Recovery Manager 8.x

Cause

  • The script clean-sras-log.sh moves the old SRA logs from the /opt/vmware/support/logs/srm/SRAs location to the /opt/vmware/support/logs/srm/olddir folder before deleting them.

  • If the /opt/vmware/support/ folder fills up during the copy phase, then the script does not complete and both the partitions will be filled to 100%.

Resolution

  • To resolve this issue:

    1. Take snapshot of Site Recovery Manager appliance VM.

    2. Manually clean up the /opt/vmware/support/logs/srm/olddir folder by deleting the files in it.

  • The /opt/vmware/support/logs partition can also be cleaned up to create more free space.

  • Once the space is freed up the clean-sras-log.sh script can be run to clear up space for the /opt/vmware/support/logs/srm/SRAs partition.