SSH service fails to start after HCX manager IP change
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SSH service fails to start after HCX manager IP change

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Article ID: 394297

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Updated On:

Products

VMware HCX

Issue/Introduction

  • You have changed HCX manager IP from the appliance management interface at <https://hcx-ip-or-fqdn:9443> Administration > Network Settings > General Network
  • SSH service fails to start even after HCX manager reboot
  • On the log /var/log/messages you see logs similar to:
sshd[#####] error: Bind to port 22 on OLDIP failed: Cannot assign requested address.
sshd[#####] fatal: Cannot bind any address.

Environment

HCX 4.10

Cause

SSH configuration does not update with the new IP

Resolution

This issue is resolved in VMware HCX 4.11, available at Broadcom downloads.
If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

Workaround steps for HCX 4.10:

  1. Open HCX manager VM console from the vCenter vSphere client
  2. Log in as root
  3. Navigate to folder /etc/ssh:
    cd /etc/ssh
  4. Take a backup of sshd_config file
    cp sshd_config sshd_config.backup
  5. Open sshd_config file with a file editor and find the line starting with ListenAddress. Comment the line by adding a # at the beginning of the line:
    # vi sshd_config
    move the cursor to the line starting with ListenAddress
    i
    #
    :wq!
  6. Start SSH service from HCX appliance management interface at <https://hcx-ip-or-fqdn:9443>, Appliance Summary tab.