vSAN Disk Management showing Disk Group unhealthy on host and displays an alarm "Disk is no longer participating in the VSAN disk group"
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vSAN Disk Management showing Disk Group unhealthy on host and displays an alarm "Disk is no longer participating in the VSAN disk group"

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Article ID: 394234

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Updated On:

Products

VMware vSAN

Issue/Introduction

  • The vSAN Disk Management screen at the cluster level in vCenter shows one disk group on host 4 as unhealthy.
  • The Unclaimed and ineligible disks section shows only a single ineligible disk.
  • The vSAN Skyline Health check shows Disk operational health check with with one disk "Unknown disk health stateā€.
  • The command line on host shows the disk as only a UUID

  • Below alarm is reflected for the host

Environment

vSAN - All versions

Cause

One disk on the host is physically failed or missing from the host and not seen by ESXi.

This can be verified by checking the host out of band management (iDRAC, iLO, etc) and seeing a failed disk, disk showing incorrect size (example: 700 MB vs 800 GB), or a disk is missing from inventory,

Resolution

Remove the disk from the disk group.

From vCenter Web Client:
1. Confirm if Deduplication and Compression is in use or not
2. Place the host into maintenance mode with Ensure Accessibility
3. a) If dedup is not in use then go to vSAN Cluster > Configure > Disk Management > Select the disk to be removed > Confirm no data impact with the Pre-Check Data Migration > If no data impact then select Remove Disk(s)
    b) If dedup is in use then the entire disk group needs to be removed and recreated. vSAN Cluster > Configure > Disk Management > Select the disk group to be removed > Confirm no data impact with the Pre-Check Data Migration > If no data impact then select Remove Disk Group


If unable to remove the disk from the group in the UI, remove from the command line.

From ssh client connected to the host with problem disk:
1. Find the disk reporting as only UUID:
     vdq -i

2. Remove the disk entry from the disk group:
     esxcli vsan storage remove -u <UUID>

Additional Information

If you have alerts for data availability, or concerns about data availability, before removing the disk please contact support.