Lost Storage Path Redundancy and Lost Storage Connectivity in a vSAN Cluster
search cancel

Lost Storage Path Redundancy and Lost Storage Connectivity in a vSAN Cluster

book

Article ID: 394044

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

Skyline health warning for vSan object health and disk showing absent on vSan cluster. Host warning lost storage connectivity.

Environment

VMware vSAN (All Versions)

Cause

When a drive is replaced in a vSAN cluster and shows as Absent, it must be manually removed from the disk group.

Resolution

  • Remove the absent disk from the disk group using the ESXi CLI.
    1. SSH into the ESXi host that owns the disk group.

    2. Identify the disk group and the absent disk using the following command:

       
      esxcli vsan storage list
    3. Remove the absent disk from the disk group:

       
      esxcli vsan storage remove -s <SSD_NAA_ID> -d <Disk_NAA_ID>
  • Identified the newly added drive as unclaimed.

  • Successfully added the new drive back into the disk group.

    1. Navigate to the vSAN cluster.
    2. Click the Configure tab.
    3. Under vSAN ,  click Disk Management.
    4. Select the disk group, and click the Add Disk.
    5. Select the device that you want to add and click Add.  (If you add a used device that contains residual data or partition information, you must first clean the device).

Reference Technical Doc : Add Devices to the Disk Group in vSAN Cluster

Reference KB for removing the absent disk from CLI: The vSAN disk appears as Absent in vSAN Disk Management

Additional Information