vSphere Replication adapter does not collect any data
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vSphere Replication adapter does not collect any data

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Article ID: 393595

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

 You have integrated your vSphere replication appliances with the Aria Operations vSphere Replication Adapter but for whatever reason you keep getting an error message not receiving any data on this adapter.

Environment

Aria Operations 8.18.2
vSphere Replication Adapter 8.18.2

Cause

Local replication is getting a 'null' value on one or more VMs for 'Details|HBR Server Name'. 

Resolution

Remove the local replication for the VM getting a null value and the adapter should start working. The issue can be found by turning on TRACE logging for the adapter. See Additional Information for enabling the TRACE level logging. The error in the logs would look similar to below.

2025-03-19T15:36:50,354+0000 TRACE [Collector worker thread 22] (19973) com.integrien.alive.common.adapter3.logger.MetricPropertyLogger.onAddMetricData - OnAddMetricData: adapter name - <Instance_Name>: adapter ID - 19973: Metric/Property data for resource - 20002, metric data - Details|Name -> <VM_Name>: Details|Direction -> Replication within the same vCenter Server: Details|Status -> error: Details|Test Recovery State -> none: Details|HBR Server Name -> null: Details|Current RPO Violation -> 0.0: Details|Is Peer Healthy -> true: Details|Transferred bytes (MB) -> 0.0: Details|Time spent in RPO violation (%) -> 0.0:

 

Additional Information

To turn on TRACE logging for the vSphere Replication adapter, perform the following steps (be sure to revert logging level after troubleshooting or log capture to avoid performance or disk issues):

  • Set the com.integrien.alive.common.adapter3 level to "trace". This will be in Administration > Control Panel Support Logs tile.
    • Navigate to the node where the vSphere Replication adapter is installed. This could be a data node or a Cloud Proxy
    • Under the proper Node select the Collector folder, then click the Gear icon at the top
    • Locate 'com.integrien.alive.common.adapter3' and change the logging level to 'trace'
    • Click OK
  • Restart collector service by SSH as root into the node the adapter is installed on and running command: service collector restart
  • Stop and start Replication adapter in the Aria Operations UI and wait for more than 5 minutes to allow time for a new collection attempt
  • Review the adapter logs in Support Logs page to validate the issue or capture a support bundle if you have a support case

Additional data to check 

  • Open the hms mob in a browser:
    • https://vrms_address:8043/mob/?vmodl=1
    • Click content, then replication-manager, and then getOutgoingReplicationGroups
    • Clear up sorters(optional) and filter(optional). In groups (required), enter the moid of the outgoing replication(the moid can be obtained from the replication page of Site Recovery UI):
      <groups type="HmsGroup">GID-xxxxx</groups>
    • Click Invoke Method. You can see the result shown. Verify hbrServerName value. 
    • Collect the database dump and logs for primary HMS

IMPORTANT: Turn trace logging back to what it was before (default should be error level). Leaving logging to trace level can cause performance and disk space issues if left enabled