Error: "The license capacity is insufficient" while applying the License to a vSAN Cluster
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Error: "The license capacity is insufficient" while applying the License to a vSAN Cluster

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Article ID: 393543

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:

  • When assigning the license: 

vCenter UI client  > Host and Cluster view > vSAN Cluster > Configure > Licensing > Assign License 

 

...the vSAN Cluster shows the error: “The license capacity is insufficient”:

Environment

vSAN ( all versions ) 

Cause

  • The vSAN license capacity is currently lower than the configured vSAN datastore size in vCenter.

  • The vSAN capacity in both Original Storage Architecture (OSA) and Express Storage Architecture (ESA) clusters is determined based on capacity usage
    • In OSA clusters, capacity usage is measured using only the capacity disks. The caching disks are excluded from this calculation.

    • In contrast, ESA clusters do not use a separate caching mechanism. Therefore, all disks contribute to the total capacity usage  

 

Validation:

  • The licensed capacity can be viewed in the Customer Connect Portal.

    • To check the configured vSAN datastore size, navigate to:

      vSphere UI Client > Datastore View > Summary Tab


Resolution

  • To resolve the issue, involve a sales representative from the respective vendor-partner to obtain the proper licensing. 

Additional Information

  • NOTE:  If you have additional keys that are not in use or excess capacity in existing keys that is not being used, then you can merge/split the license keys to create a new key with sufficient capacity in the Broadcom Support Portal.  See KB: Merge and split license keys for VMware products.