Agent 8.10.0 Policy Installer Does Not Include Configlist
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Agent 8.10.0 Policy Installer Does Not Include Configlist

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Article ID: 392566

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

When installing Windows Agent 8.10.0 using the latest Policy Installer the Configlist is not included at the time of install

Environment

  • App Control Agent: 8.10.0
  • Microsoft Windows: All Supported Versions

Cause

This issue was tracked under EPCB-23124 and resolved with the release of Agent 8.10.2.

Resolution

Upgrading the Agent Installer to 8.10.2 will prevent the issue. In the meantime, there are potential workarounds for Agent install:

  • Use one of the Unbranded Installer methods (Server.conf or manually specifying all parameters)
  • Install in Disabled mode and wait for the Configlist to fully to sync before moving the Agent to an Enforcement Policy
  • Install in Disabled mode and manually import the Configlist on Service Start before moving to an Enforcement Policy
    1. Use an Administrative Command Prompt to stop the Agent using the command:
      "C:\Program Files (x86)\Bit9\Parity Agent\dascli.exe" stopservice
    2. Obtain the latest configlist.xml from the application server, by default in: \Bit9\Parity Server\configxml\configlist.mxl
    3. Rename and copy the file to: C:\ProgramData\Bit9\Parity Agent\configlistfull.bt9
    4. Start the Agent using the Administrative Command Prompt to issue the command:
      net start parity
    5. After the Configlist is ingested by the Agent it will be recreated as ConfigListBackup.bt9