HCX inventory not showing all VMs when creating a Mobility Group
search cancel

HCX inventory not showing all VMs when creating a Mobility Group

book

Article ID: 391896

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • The inventory UI loads after selecting the source and destination sites.
  • When searching for a VM, it is not present, while other VMs are loading correctly.

    Virtual Machines not found in the container



  • The VMs can be seen from the vSphere inventory, outside out HCX.
  • In the HCX logs, the following messages can be seen:

    common/logs/admin/app.log shows UpdateInventoryJob failure messages which contain vm IDs of the missing VMs:

    2025-03-14 16:21:15.843 UTC [TopologyService_SvcThread-####, Ent: HybridityAdmin, , TxId: ##############################] ERROR c.v.v.h.vsphere.UpdateInventoryJob- DB operation failed, status: FAILURE, result: {"successes":[],"status":"FAILURE","failures":[{"row":{"val":{"entity_id":"vm-######","invSyncTime":"1741969268537","vcenter_instanceId":"##########################","enterprise":"HybridityAdmin","organization":["HybridityAdmin"],"vcenter_connection":"https://vCenterFQDN".......<truncated>

    common/logs/postgres/postgresql-<date>.log shows messages stating that the VM already exists in the database:

    2025-03-14 16:21:15.843 UTC [TopologyService_SvcThread-####, Ent: HybridityAdmin, , TxId: ##############################] ERROR c.v.v.h.vsphere.UpdateInventoryJob- DB operation failed, status: FAILURE, result: {"successes":[],"status":"FAILURE","failures":[{"row":{"val":{"entity_id":"vm-######","invSyncTime":"1741969268537","vcenter_instanceId":"##########################","enterprise":"HybridityAdmin","organization":["HybridityAdmin"],"vcenter_connection":"https://vCenterFQDN".......<truncated>

common/logs/admin/app.log can also show error related to updating DB table:

2025-10-23 08:59:14.901 UTC [TopologyService_SvcThread-273149, Ent: HybridityAdmin, , TxId: ##############################] ERROR c.v.v.h.vsphere.UpdateInventoryJob- Error updating DB table VirtualMachine with object update vm-######.

Environment

  • VMware HCX 
  • VMware vCenter 

Cause

The HCX inventory is pulled from the registered vCenter and is not being updated correctly.

Resolution

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

  • HCX connector logs
  • HCX cloud logs
  • HAR file
  • ESXi support bundles for hosts where the affected VMs are located
  • vCenter logs

Handling Log Bundles for offline review with Broadcom support: