Attempting to Remove NSX for an ESXi host Transport Node in NSX Manager fails when the host is not available in vSphere.
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Attempting to Remove NSX for an ESXi host Transport Node in NSX Manager fails when the host is not available in vSphere.

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Article ID: 391840

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Cannot Remove NSX an ESXi host Transport Node (TN) from NSX Manager through the UI when attempting to Unconfigure NSX following the normal delete or force delete operations.
  • The ESXi host has already been decommissioned or is otherwise no longer available and cannot be restored. For reference, the below links document the correct process to remove TNs from NSX:
    3.x Uninstall NSX-T Data Center from an ESXi Host
    3.x Uninstall NSX-T Data Center from a Host in a vSphere Cluster
    4.x Uninstall NSX from a Physical Host
    4.x Uninstall NSX from a Managed Host in a vSphere Cluster
  • ESXi Host Transport Nodes (TN) may show error "Uninstall failed" or status "unknown"
  • Force removal using NSX UI or API failed to remove the the transport nodes.
    • API command = DELETE https://<NSX Mgr IP>/api/v1/transport-nodes/<UUID>?force=true&unprepare_host=false
    • You typically would already have the TN UUID by this point and can get it from the NSX Manager UI. If the host isn't listed under Standalone Hosts/Other, use the magnifying glass at the top and search for the host name. The UUID can be copied from the details of the Transport Node under the search results.
    • You can also get the TN UUID via API using GET https://<NSX Mgr IP>/api/v1/transport-nodes to list all transport nodes and searching the output.

Environment

VMware NSX 4.x
VMware NSX-T Data Center 3.x

Cause

Incomplete or improper uninstallation of NSX from TNs before they are removed from NSX Manager. In most cases, if an inaccessible ESXi host must be removed and can't be restored, a Force Delete will work. However, force deletion and through NSX UI and API can still fail in some cases, particularly if the TN has already been marked for deletion.

Host TN "unknown" status may report due to compute manager status reporting it as "down"


*Note: 
A similar issue can occur after a failed attempt to configure an ESXi host as a transport node in NSX and thereafter being unable to configure the same host (or any new one with similar name, IP, etc.) with an error reporting that the node already exists. For that issue, refer to Installing or Upgrading NSX on an ESXi host fails reporting the node already exists

Resolution

If you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

  • NSX Manager support bundles.
  • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation.
  • On one of the NSX managers, login as root user and run the following two commands:
    /opt/vmware/bin/corfu_tool_runner.py --tool corfu-editor -n nsx -o showTable -t HostTransportNode > /image/HostTransportNode.txt

    /opt/vmware/bin/corfu_tool_runner.py --tool corfu-editor -n nsx -o showTable -t TransportNodeState > /image/TransportNodeState.txt

  • Upload the resultant two files: /image/HostTransportNode.txt and /image/TransportNodeState.txt

Handling Log Bundles for offline review with Broadcom support