Online repository updates in vCenter Server fail when the token lacks specific product version entitlements
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Online repository updates in vCenter Server fail when the token lacks specific product version entitlements

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Article ID: 391459

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Updated On:

Products

VMware vCenter Server 7.0 VMware vCenter Server 8.0

Issue/Introduction

vCenter Server patching fails with any of the following error messages after updating the token by following the steps in KB VCF Authenticated downloads Configuration Update Instructions:

Error copying packages:



Update is not staged:



[Errno 2] No such file or directory: '/storage/updatemgr/software-update######/stage/update/patching_backup_config.json':



Error in method invocation Timeout happens while sending message to microservice:

The /var/log/vmware/applmgmt/update_microservice.log file contains errors similar to the following:

YYYY-MM-DD HH:MM:SS - 23088 - update_functions target ::-- waitretry 1 -- connect-timeout 10 -r -np -nH -nd -A -P /storage/seat/software-update 4ftl1ri/stage https://dl.broadcom.com/#####################/PROD/COMP/VCENTER/vmw/#####################/8.0.3.00600/package-pool/010cbb2b1373b111b91e0d827a4423df0499fe206404022b92ca81add4eae3d7.blob

YYYY-MM-DD HH:MM:SS - 23088 - update_functions target :::35:32 -- https://dl.broadcom. com/#####################/PROD/COMP/VCENTER/vmw/#####################/8.0.3.00600/package-pool/010cb2b1373b111b91e0d827a4423df0499fe206404022b92ca81add4eae3d7.blob\nResolving dl.broadcom.com ... , [IP_ADDRESS], [IPV6_ADDRESS]\n Connecting to dl.broadcom.com|[IP_ADDRESS]| :443 ... connected. \nHTTP request sent, awaiting response ... \n HTTP/1.1 403 Forbidden\n Date: YYYY-MM-DD HH:MM:SS GMT\n Content-Type: text/plain; charset=UTF-8\n Content-Length: 12\n Connection: keep-alive\nServer: cloudflare\nYYYY-MM-DD HH:MM:SS ERROR 403: Forbidden. \n\n'ERROR - Exception staging containers 

Environment

  • VMware vCenter Server 7.x
  • VMware vCenter Server 8.x

Cause

  • The provided token does not have the necessary entitlements for the selected version.
  • The token has expired.

Resolution

Clean up the update state with the below steps and retry the update with a valid token:

  1. Delete the patching db:

    rm /storage/db/patching.db

  2. Verify that the file /storage/core/software-update/stage/stageDir.json exists, then check its contents:

    cat /storage/core/software-update/stage/stageDir.json

  3. If the file exists, it will specify a stageDir location similar to /storage/<subdir>/software-update####. Delete this directory and its contents by running the following command:

    rm -rf /storage/<subdir>/software-update####
    rm -rf /storage/core/software-update/stage/stageDir.json

  4. Clean up the state file.

    rm /etc/applmgmt/appliance/software_update_state.conf

  5. Configure a valid token based on the entitlement - VCF Authenticated downloads Configuration Update

  6. Retry the vCenter Server patching.

Additional Information

  • This issue can also occur if a Download Token is generated using an incorrect Site ID.
  • The vCenter Server license must be tied to the same Site ID used to generate the Download Token.