Mail server configuration not working after 16.3 upgrade
search cancel

Mail server configuration not working after 16.3 upgrade

book

Article ID: 390159

calendar_today

Updated On: 03-07-2025

Products

Clarity PPM On Premise

Issue/Introduction

We have recently upgraded the clarity application from 16.0.0 to 16.3.0. Post-upgrade mailserver settings are still enabled in CSA and we are unable to send the notification from clarity.

While working with the IT team managing the SMTP service we got the below inputs:

  • When we are triggering mails from the servers via local telnet it is getting traced in the SMTP server.
  • When we are triggering mail from the clarity application it is not getting traced in the SMTP server.

As per SMTP logs⁠

The client connects to the SMTP server on port 25.

The server acknowledges with a 220 response, indicating that it is ready to receive mail.

⁠EHLO Command

The client sends an EHLO command (EHLO clarity_server_name).

The server responds with 250 codes listing supported features, including:

Message size limit (250-SIZE 104857600 → 100MB max)

Pipelining (250-PIPELINING)

Delivery status notifications (250-DSN)

Enhanced status codes (250-ENHANCEDSTATUSCODES)

Secure connection capability (250-STARTTLS)

Authentication support (250-AUTH)

8-bit MIME support (250-8BITMIME)

Binary MIME support (250-BINARYMIME)

Chunking (250 CHUNKING)

Session End (-,Remote)------>This might indicate that the connection was closed before further communication (e.g., authentication, MAIL FROM, RCPT TO) could occur.

 

App-ca.logs (in debug):

DEBUG ...notification.MailMessage (clarity:none:none:none) () MailMessage.send() messaging error
javax.mail.AuthenticationFailedException: No authentication mechanisms supported by both server and client
  at com.sun.mail.smtp.SMTPTransport.authenticate(SMTPTransport.java:880)
  at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:780)
  at javax.mail.Service.connect(Service.java:388)
  at javax.mail.Service.connect(Service.java:246)
  at javax.mail.Service.connect(Service.java:195)
  at javax.mail.Transport.send0(Transport.java:254)
  at javax.mail.Transport.send(Transport.java:124)

notification.MailMessage (clarity:none:none:none) () MailMessage.run() send failed
com.niku.union.utility.MessageKeyException: CMN-05000: Invalid Mail Server. Contact your system administrator.

 

Cause

While testing emails from telnet it was found that the mail server did not need authentication and we were able to send emails.

Resolution

Unchecked "Use Authentication" from the Mail Server configuration in CSA. 

 

 

Additional Information