Add ESXi host to SDDC manager cluster fails at subtask - Configure NFS Datastore on ESXi hosts
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Add ESXi host to SDDC manager cluster fails at subtask - Configure NFS Datastore on ESXi hosts

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Article ID: 389376

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

Adding an ESXi host to SDDC manager, fails at Configure NFS Datastore on ESXi hosts

ESXi host logs - 

2025-02-05T15:13:39.492Z Wa(180) vmkwarning: cpu12:2103156)WARNING: NFS: 220: Got error 13 from mount call
2025-02-05T15:13:39.492Z In(182) vmkernel: cpu58:2100068 opID=68ef390a)SunRPC: 1096: Destroying world 0x2018f3
2025-02-05T15:13:39.492Z In(182) vmkernel: cpu58:2100068 opID=68ef390a)StorageApdHandler: 1051: Freeing APD handle 0x431cb8a02ec0 [04aeadaa-7defcff3]
2025-02-05T15:13:39.492Z In(182) vmkernel: cpu58:2100068 opID=68ef390a)StorageApdHandler: 1135: APD Handle freed!
2025-02-05T15:13:39.492Z In(182) vmkernel: cpu58:2100068 opID=68ef390a)
NFS: 3115: NFS mount failed for IP_ADDRESS:/datastore_name volume datastore_name. Status: The mount request was denied by the NFS server. Check that the export exists

You have validated the below steps from the KB - NFS Datastore Fails to Mount with "The mount request was denied by the NFS server" Error

  • We get a successful ping test from the ESXi host to the NFS server, however the host is not able to connect to the NFS server on port 2049. 
  • On the NFS server, it is ensured that the export configuration allows the ESXi host's IP address or subnet.
  • Engaging with Storage Vendor confirms there is no issues from the NFS side.

Environment

VMware Cloud Foundation 5.x

Cause

  • This issue can occur if the ESXi host that is being added, was existing in the cluster previously which was later decommissioned from SDDC manager.
  • After the decommission is complete the IP address from the network pool in the SDDC manager for the NFS network of the ESXI host, is not released by the cluster. 

Resolution

Update SDDC Manager Network Pool To release the IP address.

Contact Broadcom Support to resolve the issue as the resolution steps involve updating the SDDC database.