Bootbank cannot be found at path '/bootbank'
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Bootbank cannot be found at path '/bootbank'

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Article ID: 388495

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Updated On:

Products

VMware vSphere ESX 8.x VMware vSphere ESX 7.x

Issue/Introduction

Symptoms:

  • ESXi Host reports "Bootbank cannot be found at path '/bootbank'" alerts in /var/run/log/vmkernel.log and the same can be seen as a warning on vSphere Client:

  • Host reports no connection with the local storage, and unable to access the logs via SSH. (OR)

  • The logs may be accessible, but the SSH would be very slow.
  • ESXi Host is marked as "Not Responding" on vSphere Client.

  • VMs on the host may continue to run with no issues.

  • /var/run/log/hostd.log of the ESXi host reports that the bootbank is not found:

    YYYY-MM-DDTHH:MM:SS.SSSZ Hostd: --> Bootbank cannot be found at path '/bootbank'
  • In /var/run/log/vmkernel.log SCSI errors for write failures and also NO_CONNECT (H:0x1) can be seen:

    YYYY-MM-DDTHH:MM:SS.SSSZ vmkernel: cpu57:2097355)ScsiDeviceIO: 4154:Cmd(0x45bd4a129908) 0x2a, cmdId.initiator=0x430ac151f040 CmdSN 0x10e9755 from world 2097806 to dev t10.####____########_#####_____###### failed H:0x5 D:0x0 P:0x0
    YYYY-MM-DDTHH:MM:SS.SSSZ In(182) vmkernel: cpu38:2097282)HPP: HppScsiThrottleLogForDevice:523: Error status H:0x1 D:0x0 P:0x0 Invalid sense data: 0x0 0x0 0x0 from device t10.####_____######_####______________________################## repeated 20 times, hppA$
  • Run below cmd to check the status of the boot disk

    vmkfstools -Ph -v10 bootbank


    Could not open bootbank
    Error: Unable to access device, please check your connection to the device.

    OBJLIB-LIB: ObjLib cleanup done.
    WORKER: asyncOps=0 maxActiveOps=0 maxPending=0 maxCompleted=0

Environment

  • VMware vSphere ESX 7.x
  • VMware vSphere ESX 8.x

Cause


Any of the above error messages would indicate a possible connection issue between boot device and the Host. Therefore pointing to a fault with either the Boot Device itself or the Storage HBA

Resolution

 

  • Restore VM Management: If the host is in an HA-enabled cluster, reboot the host to regain control. VMware HA will automatically restart the VMs on other healthy hosts.

  • Hardware Investigation: After the reboot, regardless of whether the host powers on successfully, engage your hardware vendor to investigate the write failures and boot device disconnection.

  • Remediation: Based on the vendor's findings, replace the boot device or the HBA (Host Bus Adapter) as necessary.

 

Additional Information

  • If the logs are missing during the time of issue, check whether the scratch partition and bootbank is configured on the same device.
  • If configured on same device and do not see any log records for the duration, configure scratch partition on separate device:

Creating a persistent scratch location for ESXi 8.x/7.x/6.x

Japanese KB: Bootbank がパス '/bootbank' に見つかりません