Reconfiguring vSphere Replication Fails with Failed to register VRMS
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Reconfiguring vSphere Replication Fails with Failed to register VRMS

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Article ID: 388160

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

While Reconfiguring vSphere Replication 9.0.1, Post Upgrade from vSphere Replication 8.8, below error is encountered on VR UI.

ERROR  Operation Failed: A general system error occurred: Failed to register VRMS. Operation ID: 645cb929-fd02-4c33-9b18-97c894ce4901

  • Network connectivity between the source ESXi and the target VR is healthy
  • All the required ports are open

Issue Validation:

/opt/vmware/hms/logs/Hms.log:

Exception: NOTE: Picked up JDK_JAVA_OPTIONS: --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.base/java.util=ALL-UNNAMED --add-opens=java.base/java.util.concurrent=ALL-UNNAMED --a
dd-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED
--> WARNING: Unable to mark managed vm: unused due to: (vmodl.fault.ManagedObjectNotFound) {
-->    faultCause = null,
-->    faultMessage = null,
-->    obj = ManagedObjectReference: type = VirtualMachine, value = unused, serverGuid = null
--> }
--> vSphere Replication Appliance configuration error:vCenter Server extension configuration problem.
--> Details: Unable to register extension in vCenter Server.
--> [ msgId: com.vmware.vr.config.ext_config_failure; value: null; errorStacktrace : com.vmware.jvsl.cfg.ConfigException: Internal error.
-->     at com.vmware.jvsl.cfg.RegisterExtensionCommand.execute(RegisterExtensionCommand.java:154)
-->     at com.vmware.hms.config.helper.VcHelper.registerExtension(VcHelper.java:280)
-->     at com.vmware.hms.config.VrConfig.expressSetup(VrConfig.java:358)
-->     at com.vmware.hms.config.cli.command.ExpressSetup.run(ExpressSetup.java:59)
-->     at com.vmware.hms.config.cli.command.CommandBase.run(CommandBase.java:347)
-->     at com.vmware.hms.config.cli.App.run(App.java:146)
-->     at com.vmware.hms.config.cli.App.main(App.java:206)
--> Caused by: (vim.fault.AlreadyExists) {
-->    faultCause = null,
-->    faultMessage = null,
-->    name = null
--> }
-->     at com.vmware.hms.config.helper.VcHelper.registerExtension(VcHelper.java:287)
-->     at com.vmware.hms.config.VrConfig.expressSetup(VrConfig.java:358)
-->     at com.vmware.hms.config.cli.command.ExpressSetup.run(ExpressSetup.java:59)
-->     at com.vmware.hms.config.cli.command.CommandBase.run(CommandBase.java:347)
-->     at com.vmware.hms.config.cli.App.run(App.java:146)
-->     at com.vmware.hms.config.cli.App.main(App.java:206)
--> Caused by: com.vmware.jvsl.cfg.ConfigException: Internal error.
-->     at com.vmware.jvsl.cfg.RegisterExtensionCommand.execute(RegisterExtensionCommand.java:154)
-->     at com.vmware.hms.config.helper.VcHelper.registerExtension(VcHelper.java:280)
-->     ... 5 more
--> Caused by: (vim.fault.AlreadyExists) {
-->    faultCause = null,
-->    faultMessage = null,
-->    name = null

2025-02-11T11:43:38.743+08:00 info drconfig[01383] [SRM@6876 sub=ConfigureVrmsOp opID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx41f8-configure:b821] Exiting ConfigureVrms
2025-02-11T11:43:38.743+08:00 verbose drconfig[01383] [SRM@6876 sub=vmomi.soapStub[29] opID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx41f8-configure:b821] Resetting stub adapter; <[N7Vmacore4Http3Ext15DrUserAgentImplE:0x00007f39dc01aa08], /lookupservice/sdk>, (null)
2025-02-11T11:43:38.743+08:00 error drconfig[01383] [SRM@6876 sub=ConfigureVrmsOp opID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxx41f8-configure:b821] Operation failed
--> (vmodl.fault.SystemError) {
-->    faultCause = (vmodl.MethodFault) null,
-->    faultMessage = ,
-->    reason = "Failed to register VRMS."
-->    msg = ""
--> }

       

  • vSphere replication service will be impacted as per below screenshot:

 

Environment

vSphere Replication 9.x
VMware Live Site Recovery 9.x

Cause

  • Post upgrade of vSphere Replication from 8.x to 9.x version, stale entries of 8.x may still persist causing reconfiguration failure.
  • The Stale entries are old registrations and solution users associated with 8.x version.

        

Resolution

If the above symptoms and issue matches, please contact Broadcom Support to investigate the issue.