False alarms "edge_vm_present_in_nsx_inventory_not_present_in_vcenter" getting triggered for multiple edge nodes
search cancel

False alarms "edge_vm_present_in_nsx_inventory_not_present_in_vcenter" getting triggered for multiple edge nodes

book

Article ID: 387550

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • Edge VM Present In NSX Inventory Not Present In vCenter alarm getting raised even when edge is present there in the vCenter/Compute Manager.
  • The alarms are periodically resolved automatically.
  • Entries similar to the below may be visible in /var/log/proton/nsxapi.log
    WARN l3-tasks1 VcConnectionImpl 2223317 FABRIC [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="manager"] error while doing login to cm #######
    java.net.ConnectException: Connection timed out (Connection timed out)

    .

    .

    .

    FATAL pool-124-thread-1 EventReportSyslogSender 2223317 MONITORING [nsx@6876 comp="nsx-manager" entId="########-####-####-####-############" eventFeatureName="edge" eventSev="critical" eventState="Off" eventType="edge_vm_present_in_nsx_inventory_not_present_in_vcenter" level="FATAL" subcomp="manager"] Edge node ########-####-####-####-############ with VM moref id vm-#### is present in both NSX inventory and vCenter.

Environment

VMware NSX 4.x
VMware NSX-T Data Center 3.x

Cause

The NSX Manager queries the vCenter/Compute Manager for the presence of all the Edge Nodes at a fixed intervals of 90 minutes.
This is a separate query for each Edge Node.

If there is a connectivity issue between the NSX Manager and the vCenter/Compute Manager when the query is being executed it is possible for the operation to fail or time out, the NSX Manager presumes the Edge Note is not present in the vCenter/Computer Manager and triggers the alarm.
Connectivity issues between the NSX Manager and the vCenter/Compute manager should be investigated.

Resolution

This issue is resolved in VMware NSX 4.1.1 and later, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

 

Workaround

Disable the edge_vm_present_in_nsx_inventory_not_present_in_vcenter alarm.

To disable an alarm and resolve currently active instances of that alarm, from the NSX UI home page, navigate to Alarms | Alarm Definitions. Find the alarm you want to disable, then:

  1. Click the 3 vertical dots.
  2. Click Edit.
  3. Slide the Enable Detection slider to the left.
  4. Click Save.
            

Additional Information