The system doesn't support starting an I/O Trip Analyzer task on cluster 'XXX' which already has a running task.
search cancel

The system doesn't support starting an I/O Trip Analyzer task on cluster 'XXX' which already has a running task.

book

Article ID: 387536

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

When you attempt to start a new I/O Trip Analyzer task you receive this message:

"The system doesn't support starting an I/O Trip Analyzer task on cluster 'XXX' which already has a running task.

Environment

vSAN 7.0x

vSAN 8.0x

Cause

 I/O Trip Analyzer task in "VsanIODiagnosticsInstanceRunning" state:

2025-01-26T20:45:06.852Z info vsand[2102047] [opID=agw-0009352-455c-9bc4 VsanHostDiagnosticsSystemImpl::_QueryAndRemediateIODiagnosticsInstances] IO Diagnostics: The queried result is => [(vim.vsan.IODiagnosticsInstance) { name = 'IO-diagnostics-task-1737060877', state = 'VsanIODiagnosticsInstanceRunning', events = (vim.vsan.IODiagnosticsInstanceEvent) [], tar

gets = (vim.vsan.IODiagnosticsTarget) [ (vim.vsan.IODiagnosticsTarget) { type = 'VirtualMachine', entityId = 'vm-5688', objUuids = (str) [ 'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx', '#' ] } ], startTime = 2025-01-16T20:54:37Z, endTime = 2025-01-16T20:59:37Z }]

Resolution

Restart the vSAN management service on all hosts in the cluster by running:
/etc/init.d/vsanmgmtd restart

If restarting the service does not fix the problem, and if the cluster is healthy and not actively troubleshooting a performance issue attempt disabling/re-enabling vSAN Performance Service.

Note: Disabling/re-enabling Performance Service will wipe out any existing performance data.
 
In vCenter 8.0, to disable and re-enable vSAN Performance service, follow the below steps:


Log into RVC via vCenter SSH.
Open vCenter SSH.
Log into shell
Run the command: rvc
Login with administrator@<domain>@localhost
cd into localhost > datacenter > computers > vSAN Cluster
Then run the command to delete the vSAN performance object: vsan.perf.stats_object_delete .
Once deleted, proceed to create the vSAN performance object by using the command: vsan.perf.stats_object_create .


Note: You can also re-enable Performance Service via the vCenter Web Client.

https://knowledge.broadcom.com/external/article/317847/vsan-health-service-performance-service.html

 

For additional Troubleshooting and Resolution Steps see KB:

https://knowledge.broadcom.com/external/article/317847/vsan-health-service-performance-service.html