Quiesce guest file system shows 'No' due to missing VMware Snapshot Provider Service on Windows when taking a Quiesced Snapshot
book
Article ID: 386801
calendar_today
Updated On:
Products
VMware vSphere ESXi
VMware vCenter Server
Environment
VMware vCenter Server
VMware vSphere ESX
Cause
Issue happens because of VMware Snapshot Provider service missing within the Guest OS which might happen because of the following reasons:
- Doing a major windows upgrade such as 2012 to 2019 can sometimes remove VMware services from Windows.
- Anti-virus or security software may remove VMware Tools services.
Resolution
VMware Snapshot Provider service needs to be reregistered on the impacted VM by following the below steps:
- Login to the Guest OS VM and open CLI session with Administrator privileges.
- Run the following command to reregister the VMware Snapshot Provider service -
"C:\Program Files\Common Files\VMware\Drivers\vss\comreg.exe" -register "C:\Program Files\Common Files\VMware\Drivers\vss\VCBSnapshotProvider.dll" "VMware Snapshot Provider" "vmvss" "VMware Snapshot Provider"
- Open
services.msc
again to confirm that VMware Snapshot Provider service is registered again.
Feedback
thumb_up
Yes
thumb_down
No