After modifying the <SPECROOT>/lib/SDPM/partslist/SS.idb file on linux, the SpectroSERVER will not start.
search cancel

After modifying the <SPECROOT>/lib/SDPM/partslist/SS.idb file on linux, the SpectroSERVER will not start.

book

Article ID: 38630

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

In order to automatically Start the SpectroSERVER after a machine reboot, the <SPECROOT>/lib/SDPM/partslist/SS.idb file needs to be modified so that the AUTOBOOTSTART entry is changed from:

 
#AUTOBOOTSTART;N;
 
To:
 
AUTOBOOTSTART;Y;

After making this change in the SS.idb file you need to stop/restart the processd (ie. <SPECROOT>/lib/SDPM/processd.pl stop and <SPECROOT>/lib/SDPM/processd.pl start).  If you run a process listing you may see that the SpectroSERVER process is not running.  Also if you run the <SPECROOT>/bin/startSS.pl script, the SpectroSERVER will not start.  An error shows:
 
Problem with extracting / launching the SS install ticket:
 
    No such file or directory:

 

Environment

Spectrum installed on Linux or Solaris

Cause

The problem is that the CA Spectrum processd is unable to determine the user to start the SpectroSERVER process as. 

Resolution

In the <SPECROOT>/lib/SDPM/partslist/SS.idb file there is a "TICKETUSER" entry.  If you are receiving this error on Solaris or Linux then you need to uncomment the TICKETUSER entry and verify that the username matches the user in the initial_user_model_name referenced  in the $SPECROOT/SS/.vnmrc file. If the users do not match you need to update the TICKETUSER field to match the entry in the .vnmrc file.  Do not change the .vnmrc entry.

For example, in the <SPECROOT>/lib/SDPM/partslist/SS.idb file change this:

#TICKETUSER;spectrum;

 

To:

TICKETUSER;spectrum;

 

You will need to stop and restart the processd again for the change to take effect.  Now if you run a process listing you will see that the SpectroSERVER process is running.

 

NOTE:  It is not recommended to use/uncomment the "#AUTORESTART;N;" option in the SS.idb as this can lead to undesirable results as the SpectroSERVER process will not be down long enough to perform administrative tasks.  For example, if you need to stop the SpectroSERVER process for any reason (like a reboot) and the AUTORESTART option is enabled, the SpectroSERVER will shut down and immediately start back up.  If you then reboot the machine, you will crash the SpectroSERVER and corrupt the database.



 

Additional Information

Please reference the "Install Tickets Files" section of the documentation for more information.

Starting in Spectrum 10.4.2.1, processd.pl script will now also stop the SpectroSERVER and Archive Manager

https://knowledge.broadcom.com/external/article?articleId=201598