NSX Edge Bridge Profile Deletion task stuck "In Progress" State
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NSX Edge Bridge Profile Deletion task stuck "In Progress" State

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Article ID: 384241

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Updated On:

Products

VMware NSX

Issue/Introduction

  • In the NSX UI, You attempted to delete the Edge Bridge Profile.

  • Deletion task is stuck "In Progress" state, with no option to perform further actions

    NSX Manager -> Networking -> Segments -> Profiles -> Edge Bridge Profile

  • You will notice the following errors in the NSX Manager logs,
    • /var/log/syslog
      2024-11-03T12:49:27.871Z <NSX Manager FQDN> NSX 77039 FABRIC [nsx@6876 comp="nsx-manager" errorCode="MP8923" level="ERROR" subcomp="manager"] Cannot delete BridgeEndpointProfile BridgeEndpointProfile/XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXX. It is being used by few bridge endpoints
      2024-11-03T12:49:27.872Z <NSX Manager FQDN> NSX 77039 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM500015" level="ERROR" subcomp="manager"] ProviderInvocationTask: 1583703720 - Failed to invoke provider L2BridgeEndpointProfileProviderNSXT

    • /var/log/proton/nsxapi.log
      2024-11-03T12:49:27.871Z ERROR providerTaskExecutor-1-33 BridgeEndpointProfileServiceImpl 77039 FABRIC [nsx@6876 comp="nsx-manager" errorCode="MP8923" level="ERROR" subcomp="manager"] Cannot delete BridgeEndpointProfile BridgeEndpointProfile/XXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXX. It is being used by few bridge endpoints
      2024-11-03T12:49:27.872Z ERROR providerTaskExecutor-1-33 ProviderInvocationTask 77039 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM500015" level="ERROR" subcomp="manager"] ProviderInvocationTask: 1583703720 - Failed to invoke provider L2BridgeEndpointProfileProviderNSXTcom.vmware.nsx.management.switching.common.exceptions.SwitchingException: null

  • In some scenarios, also trying to create a new Edge Bridge Profile, gets stuck in "Uninitialized".

  

Environment

VMware NSX 

Cause

When the Delete was attempted, there were still bridge endpoints attached to the Edge Bridge Profile and prevented the Profile from being deleted.



Resolution

  • Prior to removing the Edge bridge profile, remove any attached endpoints.

  • If you have already attempted to delete the profile and now have the "In Progress" status, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

  • NSX Manager support bundles.
  • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation.

Handling Log Bundles for offline review with Broadcom support