"Failed to load cluster details. Failed to get hosts from DB" error after an unsuccessful cluster deletion attempt on SDDC Manager
book
Article ID: 383709
calendar_today
Updated On:
Products
VMware SDDC Manager / VCF Installer
Issue/Introduction
Deleting a cluster from SDDC Manager fails with the following error: "Failed to load cluster details. Failed to get hosts from DB"
ESXi hosts were decommissioned from the vCenter leading to out of band modifications on the cluster.
The cluster and its associated hosts are in deactivating state on the SDDC Manager.
Environment
SDDC Manager 4.x
SDDC Manager 5.x
SDDC Manager 9.x
Cause
The issue occurs when the Hosts in the cluster are manually deleted from the vSphere Client and NSX, but have not been completely removed from the SDDC Manager, resulting in stale leftovers in the SDDC Manager database.
Resolution
Contact Broadcom support for assistance with removing cluster references from the SDDC Manager database.