Cannot Update Service Account Credentials Because the Account is Locked Out
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Article ID: 383664
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Updated On:
Products
Carbon Black App Control
Issue/Introduction
- Issues trying to change the service account credentials because the service account is getting locked in Active Directory
- The account can be unlocked but goes back to being locked
Environment
- App Control Server: All Supported Versions
- Windows OS: All Supported Versions
Cause
Typically an account is automatically re-locked in Active Directory when an application or service is repeatedly using outdated/invalid credentials.
Resolution
- Temporarily change the service Startup Type to Disabled
- Open Services (Start > Run > services.msc > Ok)
- Change the Startup Type to Disabled for both
- Carbon Black App Control Reporter
- Carbon Black App Control Server
- Verify the services are not currently attempting to start and remain stopped.
- Temporarily stop the IIS Site and Application Pools
- Open IIS Manager > select the server name
- From the right-hand menu > Manage Server > Stop
- From the left-hand menu > expand server name > select Application Pools
- Right click each Application Pool > Stop
- AppCDownloads
- DefaultAppPool
- Verify the account in Active Directory has not re-locked.
- Follow the steps to update the Service Account on the services and IIS accordingly, but do not start any services yet.
- Start the services individually before changing the Startup Type
- Start the Carbon Black App Control Server.
- Verify the service remains running and the account has not re-locked.
- Change the Startup Type to Automatic.
- Repeat accordingly with the Carbon Black App Control Reporter.
- Start the IIS Site and Application Pools
- IIS Manager > select server name > right-hand menu > Manage Server > Start.
- Expand the server name > Application Pools > start the DefaultAppPool
- Verify the Application Pool remains running and the account has not re-locked.
- Repeat accordingly with AppCDownloads
- Verify the Console is accessible and the account has not re-locked.
Additional Information
- The security log in the event logs can be used to try to get more information about what is causing the account to get locked
- The account being locked can cause this error while updating the credentials "The specified password is invalid. Type a new password."
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