Instances are appearing on the openstack CLI and not in Horizon UI
search cancel

Instances are appearing on the openstack CLI and not in Horizon UI

book

Article ID: 382545

calendar_today

Updated On:

Products

VMware Integrated OpenStack

Issue/Introduction

  • Querying instance has different results (found/not found) based on query and where you query from.
  • Dashboard Stuck on 'Deleting' Status,
  • CLI Shows Missing Servers
  • Failed creation of instances
  • Deploying a stack, the process is ending with failure

Environment

7.x

Cause

  • Instance did not properly create and did not get proper inputs in all Openstack databases
  • Some queries only look in instance tables while others also query the cell mappings.

Resolution

Please open a support ticket with Broadcom Support.

Please run thru the steps below and upload those files to the support ticket.

Additional Information

Support will need a copy of the following Openstack databases to review and determine course of action.   nova, nova_api, nova_cell0 

#osctl exec -it mariadb-server-0 bash
#mysqldump --defaults-file=/etc/mysql/admin_user.cnf --host=localhost  <database> /tmp/<database>.sql
#exit

#osctl cp openstack/mariadb-server-0:/tmp/<database>.sql /tmp/<database>.sql

Then you just pull the backup from the manager.  Use something like winscp.