Scheduled NSX backups never run while manual backups succeed
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Scheduled NSX backups never run while manual backups succeed

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Article ID: 381887

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Updated On:

Products

VMware NSX

Issue/Introduction

  • You have configured automatic backups of NSX managers to run on any schedule.
  • Manual backups succeed and produce backup files on the target SFTP server, however no files are produced at the times of scheduled backups.
  • The backup history shows no sign of the scheduled backups running, only listing the manual backups.
  • One previous Manager instance in this cluster was deleted.
  • In the VIP-carrying Manager instance, the file /var/log/proton/nsxapi.log contains lines similar to this one at the times of scheduled backups:
    2024-09-24T10:00:00.000Z  WARN policyProviderTaskScheduler-9 RefreshGlobalAlarmsTask 5141 POLICY [nsx@6876 comp="nsx-manager" level="WARNING" subcomp="manager"] Not a leader, ignoring scheduled task

Environment

VMware NSX

Cause

In some circumstances the previous instance of NSX manager is not completely cleaned up from all of the cluster's database, resulting in the 'leader' status for scheduled tasks to end up associated with the UUID of the deleted node, instead of any of the existing nodes, causing the scheduled tasks of backup to be skipped by all the nodes.

Resolution

This is a known issue impacting VMware NSX.

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

  • NSX Manager support bundles.
  • ESXi host support bundles for hosts that are failing to configure as transport nodes.
  • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation.

Handling Log Bundles for offline review with Broadcom support