"Error: One or more relationships exist for object with id TransportNode/[UUID] from NSGroup/[UUID]" when editing NSX prepared host or attempting to uninstall NSX
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"Error: One or more relationships exist for object with id TransportNode/[UUID] from NSGroup/[UUID]" when editing NSX prepared host or attempting to uninstall NSX

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Article ID: 381813

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX was removed/disabled as a data source within VRNI, at some point in the past.
  • Any attempt to change configuration within NSX or uninstall NSX from a host may fail with error.

Error: One or more relationships exist for object with id TransportNode/[UUID] from NSGroup/[UUID]. (Error code: 3022)

  • NSX Manager UI > Inventory > Groups contains group(s) with name vRNI-Node_Group_Profile[ID]
  • If vRNI is no longer in use and you attempt to delete the group, it fails with error:

NSGroup vRNI-Node_Group_Profile_ is being used by ServiceConfig and cannot be deleted.

  • If vRNI still configured and in use, the host may be part of a group.

Environment

VMware NSX

Cause

This issue occurs due to stale entries which may remain in NSX when vRNI is no longer used or was vRNI is still in use, but was unconnected and reconnected in the past, this may lead to stale groups in NSX.

Resolution

This issue is resolved in VMware NSX 4.2.2, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

 

To workaround the issue, if vRNI is still in use and the groups with prefix 'vRNI' still exist, to identify which groups are stale, you can disable NSX-T data collection in vRNI, the profile and collector in NSX should be removed then.

Whichever vRNI group(s) remain, are the stale groups.

You should now be able to delete the stale groups in NSX while vRNI is unconfigured.

Note: In some cases, these may be nested groups and you will need to first remove the reference in the parent group, to delete the group with the hosts in it.

 

If vRNI is no longer in use, and you are unable to remove the vRNI groups, please open a case with Broadcom Support and reference this KB article.

Follow instructions here to created support case: Creating and managing Broadcom support cases