NSX Manager is currently operating without a valid license. To rectify this situation, please verify NSX Manager's license or entitlement from vCenter Server in the next <X> days.
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NSX Manager is currently operating without a valid license. To rectify this situation, please verify NSX Manager's license or entitlement from vCenter Server in the next <X> days.

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Article ID: 381087

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Updated On:

Products

VMware NSX

Issue/Introduction

  • NSX is licensed using VCF license.
  • NSX 4.1.2.3 or higher, recently upgraded to NSX 4.2.x
  • All VCF single licenses in the NSX may become invalid due to:
    • The license expired, or
    • License doesn't exist in the vCenter, or
    • vCenter is disconnected from NSX Manager.
    • vCenter certificate has been revoked,
    • Compute Manager was removed from NSX Manager. 
  • NSX Manager will display a yellow banner similar to the banner below, with days counting down:
  • NSX Manager's logs may show change of entitlement as below:
    /var/log/proton/nsxapi.log:
    2024-09-06T13:14:46.047Z  INFO LicenseSynchronizeVCTask LicensingModeHandlerImpl 75781 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Handle license mode event for group vc.vcf with event NOTHING, mode from GRACE_PERIOD to GRACE_PERIOD

Environment

  • NSX 4.1.2.3 or higher, recently upgraded to NSX 4.2.x

Cause

This issue is caused by internal referencing to license name that doesn't exist. 

Resolution

  • This is a known issue, which will be fixed in future product release. 
  • If the conditions below are true, this banner can be considered benign:
    • The VCF single license is not expired, and 
    • The vCenter did not assign another license to vCenter (asset),
    • The NSX Manager can connect to the Compute Manager (vCenter),
    • vCenter's certificate has not been revoked,
    • Compute Manager (vCenter) has not been removed from NSX.
  • Once the countdown reach 0, the banner will disappear, with no impact to the environment, or functionality of the product. 
  • For a workaround, please open a new ticket with Global Support team, and refer to this KB article.