Aria Suite Lifecycle Fails to Map VIDM 3.3.7 Binaries Due to Checksum Error Code: LCMSOURCEMAPPING10018
search cancel

Aria Suite Lifecycle Fails to Map VIDM 3.3.7 Binaries Due to Checksum Error Code: LCMSOURCEMAPPING10018

book

Article ID: 380977

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

When attempting to map VMware Identity Manager (VIDM) 3.3.7 binaries to Aria Suite Lifecycle, the operation fails with the following error:

Error Code: LCMSOURCEMAPPING10018

Selected files checksums does not match with any product versions supported by VMware Aria Suite Lifecycle.

One or more selected files checksums does not match with any product versions supported by VMware Aria Suite Lifecycle:   
 [/data/identity-manager-3.3.7.0-21173100-updaterepo-lcm.tar.gz]

 

 

In  /var/log/vrlcm/vmware_vrlcm.log you see below error

202X-XX-XXTxx:xx:xx.xxx ERROR vrlcm[xxxx] [pool-3-thread-18] [c.v.v.l.d.s.h.SourceMappingUtil]  -- The checksum of the zip file seems to be incorrect.

This error indicates that the checksum of the uploaded binary file does not match any of the checksums for VIDM 3.3.7 that are recognized by Aria Suite Lifecycle.

 

Environment

Aria Suite Lifecycle 8.x

Cause

This issue is typically caused by a corrupted VIDM 3.3.7 binary file.  Corruption can occur during the download process.

Resolution

To resolve this issue, re-download the VIDM 3.3.7 binaries from the Broadcom support portal. Ensure that the download completes successfully and is not interrupted. After downloading the new binary file, attempt to map it to Aria Suite Lifecycle again.

Additional Information

Refer https://knowledge.broadcom.com/external/article/142814/download-broadcom-products-and-software.html for steps to download binaries from the Broadcom Support Portal

Refer https://knowledge.broadcom.com/external/article/368614/aria-suite-lifecycle-no-longer-supports.html for steps to download the content from the Broadcom support portal and upload/map in Aria Suite Lifecycle