Installation or Upgrade of cb-enterprise or Sensor Packages Fails with a 401 Error
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Installation or Upgrade of cb-enterprise or Sensor Packages Fails with a 401 Error

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Article ID: 380838

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Updated On:

Products

Carbon Black EDR

Issue/Introduction

When attempting an installation or an upgrade of the server or sensor packages, a 401 error message is given when reaching out to the CarbonBlack repository.

CarbonBlack                                                                                                                                                   23  B/s |  99  B     00:04
Errors during downloading metadata for repository 'CarbonBlack':
  - Status code: 401 for https://<username>:<access_token>@packages.broadcom.com/artifactory/carbonblack-edr/7.9.0-1/8/x86_64/repodata/repomd.xml (IP: <IP>)

Environment

  • Carbon Black EDR Server: All Versions

Cause

Username or Access Token is incorrect or expired. 

Resolution

  1. Check the username is the one used for your support.broadcom.com login.
  2. Verify the registry token used is correct. My Downloads > Registry Token.
    1. Validate the token is associated with the Carbon Black EDR entitlement. 
    2. Validate the token expiration date. 
  3. Attempt to generate a new registry token for the Carbon Black EDR entitlement. Authenticate to Packages Repository