Installation or Upgrade of cb-enterprise Fails with a 400 Error
search cancel

Installation or Upgrade of cb-enterprise Fails with a 400 Error

book

Article ID: 380838

calendar_today

Updated On:

Products

Carbon Black EDR

Issue/Introduction

When attempting an installation or an upgrade, a 400 error message is given when reaching out to the carbonblack repository

Updating Subscription Management repositories.
CarbonBlack                                                                                                        415  B/s | 215  B     00:00
Errors during downloading metadata for repository 'CarbonBlack':
  - Status code: 400 for https://yum.distro.carbonblack.io/enterprise/7.8.0-1/8/x86_64/repodata/repomd.xml (IP: 3.88.77.87)
Error: Failed to download metadata for repo 'CarbonBlack': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

Environment

  • Carbon Black EDR Server: All Versions

Cause

carbonblack-alliance-client certificate set is expired.

Resolution

  1. Download the newer rpm installation file from the Entitlements > License page. 
    1. If the rpm file is not there, please reach out to your account manager or Broadcom Global Support to generate the rpm. Product support will be unable to assist with generating this file.
  2. Place the new rpm file on the server
  3. Run the following command to update the Alliance certificate 
    rpm -ivh --force <filename>.rpm
  4. Continue with the installation or upgrade.

Additional Information

  • Any rpm file with 1.0.4 or higher will have the updated sha256 certificate.