Incompatible plugin plugincom.vmware.h4.vsphere.client
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Incompatible plugin plugincom.vmware.h4.vsphere.client

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Article ID: 380699

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Plugin plugincom.vmware.h4.vsphere.client observed as incompatible in vSphere UI



Environment

vCenter Server 8.x

vCenter Server 7.x

Cause

CVE-2021-21986 - VMSA-2021-0010 (Virtual SAN Health Check, Site Recovery, vSphere Lifecycle Manager, and VMware Cloud Director Availability Plugins)
How to Disable VMware Plugins in vCenter Server per VMSA-2021-0002, VMSA-2021-0010, VMSA-2021-0010 


plugincom.vmware.h4.vsphere.client is the Default vCloud Availability plugin for vCloud Director that ships with a vCenter Server deployment and it uses the deprecated local plugin architecture and this particular version of plugin is no longer applicable or compatible with vSphere 8



Resolution


To remove this plugin confirm the plugin is not being used for ELM or Cloud director before implementing the steps.


  •  Take s snapshot of the vCenter server before removing the plugin.

https://knowledge.broadcom.com/external/article/313886/vmware-vcenter-in-enhanced-linked-mode-p.html

  •  SSH to the VCSA as root
  •  Use the Lookup Service utility (lstools.py) to find the service ID for the plugin you which to unregister by running the following command:

/usr/lib/vmware-lookupsvc/tools/lstool.py list --url http://localhost:7090/lookupservice/sdk --product com.vmware.h4

You should get back only 1 single response and make a note of the Service ID which is required in the next step.

Service Product: com.vmware.h4
        Service Type: vsphere.client
        Service ID: <service_id>
        Site ID: default-first-site
        Node ID: <node_id>
        Owner ID: [email protected]
        Version: 0.4.3.0
        Endpoints:
                Type: com.vmware.cis.vsphereclient.plugin
                Protocol: http
                URL: [...]
                SSL trust:[...]

  •  unregister the plugin by providing the Service ID along with the administrator credentials by running the following command:

/usr/lib/vmware-lookupsvc/tools/lstool.py unregister --url http://localhost:7090/lookupservice/sdk --id <service_id> --user administrator --password "SSOPassword"

 

  •  Restart the vSphere UI Client service with one of the following commands

service-control --restart vsphere-ui
or
vmon-cli -r vsphere-ui