Compute Manager Registration Status is stuck "in Progress"
search cancel

Compute Manager Registration Status is stuck "in Progress"

book

Article ID: 380503

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • You are running VMware NSX 4.X.

  • Compute Manager Registration Status stuck at "in Progress"

Environment

  • VMware NSX.

Cause

  • If the user has read-only permissions, the behavior is expected.

  • Attempting to delete the vCenter extension will result in an error. The vCenter will throw a com.vmware.vim.binding.vim.fault.NoPermission exception. As a result, the extension deletion fails.

  • This failure causes the Compute Manager update to fail and remain in progress.

Resolution

  • This issue is resolved in VMware NSX  4.2.0 available at Broadcom downloads.

  • Re-registering with a user who has administrative access.

Additional Information

  • When we update the vCenter user in the Compute Manager object, the system will attempt to delete the old vCenter extension and create a new one. This needs to be done using an account with full access.

  • Starting with NSX version 4.2.x, this "stuck in progress" issue will be resolved, and the system will fail immediately, indicating that it is related to insufficient permissions.
  • If you are contacting Broadcom support about this issue, please provide the following:

    • NSX Manager support bundles.
    • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation.

    Handling Log Bundles for offline review with Broadcom support