vSphere Replication fails to establish a connection following a vCenter certificate change(Cannot complete login due to an incorrect user name or password)
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vSphere Replication fails to establish a connection following a vCenter certificate change(Cannot complete login due to an incorrect user name or password)

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Article ID: 379628

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • Post vCenter certificate change, VRMS shows as Not Connected on site pairing.
  • Re-configure works fine.
  • Pairing errors out with Invalid User name or Password while the user credentials are valid.
  • Cannot connect the pair due to thumbprint mismatch message.
  • vSphere Replication Management Server could not establish connection to remote vSphere Replication Management Server.

dr.log

Caused by: com.vmware.srm.client.reactive.impl.request.RequestContext$RequestCompleted: Cannot complete login due to an incorrect user name or password.
Caused by: (vim.fault.InvalidLogin) {
   faultCause = null,
   faultMessage = null
}
        at java.base/jdk.internal.reflect.DirectConstructorHandleAccessor.newInstance(Unknown Source)
        at java.base/java.lang.reflect.Constructor.newInstanceWithCaller(Unknown Source)




Environment

VMware vSphere Replication 9.x

Cause

  • The DB table had a stale node entry on one of the sites. 
  • Thumbprint of Prod site vCenter certificate not matching with node on DR site.

 

Resolution

If the above symptoms and issue matches, please contact Broadcom Support to investigate the issue further.

Additional Information

hms and hbrsrv service needs to be stopped before making changes to DB.

root@prod-vr [ ~ ]# systemctl stop hms
root@prod-vr [ ~ ]# systemctl stop hbrsrv