Connector Xpress 2.0 - unable to configure Identity Manager Server Details
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Connector Xpress 2.0 - unable to configure Identity Manager Server Details

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Article ID: 379185

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Updated On:

Products

CA Identity Manager

Issue/Introduction

In Connector Xpress version 2.0, when trying to "Configure Identity Manager Server" it reports 

Failed to save 'XX.XX.XX.XX' Identity Manager Server details. Invalid Host Name, Environment or other details found.

 

Environment

Connector Xpress v2.0

Cause

Incorrect value(s) submitted for IM server parameters.

Resolution

From the Connector Xpress 2.0 machine, verify that you can get to the IM environment (IME) via browser, ex. 

         http://idm.test.com:8080/iam/im/IdentityEnv

and validate the environment's login credentials.

 

In the Connector Xpress screen for Configure Identity Manager Server, ensure the correct values are submitted as follows.

Host Name / IP Address:

This is the Identity Manager Server where the IME is running, not the Prov server.  

For example,  idm.test.com or its IP address.

 

Port:

This is the port where the environment is accessible at its application server.

For example,  8080

 

User Name:

Password:

The user name and password for logging into the IME on the IM server. This refers to the Identity Manager application server environment, like http://idm.test.com:8080/iam/im/IdentityEnv, as an example. It does not refer to the Provisioning Server.

For example,

User Name: imadmin

Password:  imtest

 

If the above still fails try setting logging as described here:

https://knowledge.broadcom.com/external/article/273484/connector-xpress-20-for-rest-application.html