CCS error: 'Unix Data Collector: An error occurred while creating RMS scopes. [Field] not found: [Unix.Machine.AIXVIOSVERSION]'
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Article ID: 377821
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Updated On:
Products
Control Compliance Suite Standards ServerControl Compliance SuiteControl Compliance Suite Standards Module
Issue/Introduction
Control Compliance Suite (CCS)
When running a data collection job or an Asset Import job on a UNIX\Linux asset, the data collection job returns the following error:
Unix Data Collector: An error occurred while creating RMS scopes. [Field] not found: [Unix.Machine.AIXVIOSVERSION]
Environment
CCS 12.6.X
CCS 12.7.0
SCU 2023-1 or newer (New fields were added to 2023-1 for AIX VIOS) to be applied to the Application server and all managers
Cause
It can be one of the following:
The remote CCS manager running the data collection does not have the same SCU applied as the CCS Application Server
The CCS services on the CCS Manager need to be stopped and restarted.
When the SCU was applied to the manager, some files were in use and were not updated.
Resolution
See the following resolutions for this issue
The remote CCS manager running the data collection does not have the same SCU applied as the CCS Application Server Verify that the CCS Application server is running at least SCU 2023-1 and that all CCS managers have the same SCU applied. Even managers that are not in a data collection role need to be at the same SCU version as the Application server. There are a couple ways to verify this, but usually the easiest way is in the CCS console go to Admin -> LiveUpdate, and look at the section CCS_12_x_20XX-X_SCU (the number will vary depending on the SCU version). Verify that the managers are at the same SCU level as the Application Server, and it has been deployed on the manager.
Example of the Application Server and remote manager at the same SCU level and it is deployed:
Make sure the 'Installed Version'of all the CCS managers is the same as the Application Server.
The CCS services on the CCS Manager need to be stopped and restarted. If the CCS manager has the correct SCU applied, stop and restart the 'Symantec CCS Manager' service and the 'Symantec Data Processing Service' service to see if that resolves the problem.
When the SCU was applied to the manager, some files were in use and were not updated. Sometimes when you apply an SCU to a manager, if a file that needs to be replaced is in-use at the time when the SCU is applied so the file is not updated. See the following KB to be able to manually update those files on the manager. Error while replacing updated .dll files during a CCS upgrade or content installation