This process requires deleting the vmware-system-tmc namespace.
When you attempt to delete the vmware-system-tmc namespace, the command hangs and/or the namespace stays in Terminating state
$ kubectl delete namespace vmware-system-tmc
$ kubectl get namespace NAME STATUS AGE vmware-system-tmc Terminating 478d
Attempts to delete the vmware-system-tmc forcefully (using --force option) is not successful
Errors:
If you describe vmware-system-tmc namespace you see errors similar to the following:
Discovery failed for some groups, 2 failing: unable to retrieve the complete list of server APIs: identity.concierge.pinniped.tmc.cloud.vmware.com/v1alpha1: the server is currently unable to handle the request, login.concierge.pinniped.tmc.cloud.vmware.com/v1alpha1: the server is currently unable to handle the request"
State:
The cluster may report as DisconnectedUnknown in the Tanzu Mission Control console web UI
Environment
Tanzu Mission Control
vSphere IaaS Control Plane (formally known as vSphere with Tanzu)
Cause
In this scenario, the vmware-system-user account had expired for the workload cluster.
First, the expired system account had to be resolved.
Resolution
As a customer operator:
Follow the below KB to resolve the expired account. vmware-system-user in this example: