Installation of NSX VIBs on host fails due to Compute Manager down
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Installation of NSX VIBs on host fails due to Compute Manager down

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Article ID: 377334

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Installation of NSX on ESXi host fails at Configuration complete step or never initiates
  • Clicking the view errors link, a heartbeat error is shown: Heartbeating between NSX management node and host ########-####-####-####-############ is down.
  • Optional symptom could also present itself in the form of the cluster not updating inside NSX to hsow the new hosts are present regardless of configured/unconfigured status.
  • Under Compute Managers, the Connection Status is Down: Compute Manager ######## cannot be connected, as its thumbprint does not match. Please edit compute manager details if thumbprint is changed.

Environment

VMware NSX-T 3.x
VMware NSX 4.x

Cause

This problem occurs because the connection between vCenter and NSX is down, this can be due to the thumbprint of the certificate that NSX Manager holds is different from the updated thumbprint following the replacement of the vCenter Server certificate.

Resolution

  1. Restore the Compute Manager connection as instructed in the article dedicated to that condition: After vCenter Server certificate is replaced, compute manager connection is "Down" on NSX UI
  2. Retry the installation of NSX on the ESXi host by clicking the Resolve button (click the error, then Resolve) if it does not automatically begin on its own.

Additional Information

If you need assistance, you can create a case with Broadcom Support. See the below links:

Handling Log Bundles for offline review with Broadcom support: