User session is timed out prior to the configured Session Inactivity Timeout
search cancel

User session is timed out prior to the configured Session Inactivity Timeout

book

Article ID: 376864

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Access to Aria Operations web UI is performed through an external load balancer (F5 Big-IP, Citrix NetScaler, NSX Advanced Load Balancer, etc)
  • Clicking on Aria Operations dashboard signs out from the UI after a few minutes.
  • No changes have been performed in the Session Inactivity Timeout settings under Administration > Global Settings > System Settings
  • Any Clicks on Aria Operations Portal  prompts back to login screen
  • Aria Operations logs you off after 5 minutes when the Session Inactivity Timeout is set for 30 minutes (or more)

Environment

VMware Aria Operations 8.x

Cause

The external load balancer (ELB) is not configured with session persistence, sticky sessions, session affinity, etc.

Resolution

To verify an issue with the external load balancer, access the Aria Operations web UI using the IP or FQDN of the primary node in the url. The session should persist until the configured Session Inactivity Timeout.

Refer to the documentation of the chosen external load balancer for steps to enable session persistence, sticky sessions, session affinity, etc.