User session is timed out prior to the configured Session Inactivity Timeout
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User session is timed out prior to the configured Session Inactivity Timeout

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Article ID: 376864

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Access to Aria Operations web UI is performed through an external load balancer (F5 Big-IP, Citrix NetScaler, NSX Advanced Load Balancer, etc)
  • Clicking on Aria Operations dashboard signs out from the UI after a few minutes.
  • No changes have been performed in the Session Inactivity Timeout settings under Administration > Global Settings > System Settings
  • Any Clicks on Aria Operations Portal  prompts back to login screen
  • Aria Operations logs you off after 5 minutes when the Session Inactivity Timeout is set for 30 minutes (or more)
  • Users report that Aria Operations is "kicking them out" after a few minutes of use causing them to have to constantly sign in while working.
  • This issue is not allowing you to save changes to any updates made in the application
  • The browser will have a popup message:

"Leave site? Changes you made may not be saved"

Environment

VMware Aria Operations 8.x

Cause

  • The external load balancer (ELB) is not configured with session persistence, sticky sessions, session affinity, etc.
  • When checking NSX Load Balancer session persistence, you may see the server pools related to Aria Operations show a Status of Degraded

NOTE: If you are unable to resolve the server pool degraded state, please open a case with the NSX team.

Resolution

To verify an issue with the external load balancer, access the Aria Operations web UI using the IP or FQDN of the primary node in the url. The session should persist until the configured Session Inactivity Timeout.

Refer to the documentation of the chosen external load balancer for steps to enable session persistence, sticky sessions, session affinity, etc.