NSX logical segments are in an inconsistent state, appearing as stale Distributed Port Groups in vCenter or reporting 'failed' via the NSX Manager API (GET /api/v1/logical-switches/state).
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NSX logical segments are in an inconsistent state, appearing as stale Distributed Port Groups in vCenter or reporting 'failed' via the NSX Manager API (GET /api/v1/logical-switches/state).

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Article ID: 375772

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Updated On:

Products

VMware NSX

Issue/Introduction

vCenter is used as a Compute Manager in NSX deployment.

  • In Networking tab in the vCenter, NSX networks which have been deleted in NSX Manager, are still present.
  • On NSX Manager, logical segments are in "failed" state in GET https://<nsx-manager-ip>/api/v1/logical-switches/state or do not appear at all.
  • Port groups shown in vCenter are not present on the ESXi hosts, verified with 'esxcfg-vswitch -l'

Environment

VMware NSX 4.x

Cause

During NSX logical segment creation or deletion, intermittent problems, such as connectivity failures, can cause the logical segment to transition into a "failed" state. When a segment is in this "failed" state, the NSX Manager's internal auto-rectification mechanism is unable to correct the issue.

This leads to:

  • During Creation: Port groups failing to be provisioned in vCenter.
  • During Deletion: Existing port groups not being cleared from vCenter, resulting in stale entries.

Resolution

This issue is resolved in VMware NSX 4.1.2.5, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.

Please refer to VMware NSX 4.1.2.5 Release Notes, "Fixed Issue 3413790" discussed in section "Resolved Issues".

 

Workaround:

To attempt rectification of a stale/orphan port group:

Stale/orphan port groups must be manually deleted from the vCenter's database. 

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

To attempt rectification of a failed logical segment:

In the NSX UI, edit the segment's 'Description' field. Make a minor, non-substantive change (e.g., type a character and then immediately backspace to remove it), then save the updated segment.